PC-1600

Hello everyone,
I just recently purchased a defective old PC-1600.  Turns out I got a great deal as the auction price was low, and when I received it two days later, I find it to be in excellent physical condition.  The exceptions being that it wasn't operable, and when I opened it up, I found substantial battery corrosion which had been eating away at the traces on the board and some of the components.  I did end up repairing some of the smaller traces which had corroded closest to the holes.  Just some simple jumpers with solder.  Still not working after I assemble it.  Go back and start replacing components with the most corrosion on their leads.  Still not working.  Finally after two more tries and replacing a diode and 7 resistors, I got it working.  I've already purchased the 2.3 EPROM and non-volatile SRAM as upgrades, just waiting on them.  I plan on using my PC-1600(X) with two Matrix-1000's, D-550, DX21, Rebirth, SoundDiver  and possibly everything else I have. 
My big question is how do I load these patches into my PC-1600X?  Do I need a Windows machine with a sequencing program to load them in?  I'm running ProTools on a G4, but I do have an old PC laptop to use if need be. 
Thanks,
Ciesz

Comments

  • Congratulations on the nice repair!

    You can load the patches with your Mac - use a sysex sending program (like Sysex Librarian - http://www.snoize.com/SysExLibrarian/ ).
  • Dan,
    Thank you for the info.  Still waiting on the upgrades as I'm hoping they will make life a little easier.  So I can convert the .mid files to .syx files with SysEx?  Some of the other patches are .exe files I'm assuming, which will not work for me.  I'll let you know how I make out when the upgrades are installed.
    Chris
  • I'm not positive, but in my previous experience, if an application doesn't open one file type or the other (.mid or .syx), changing the suffix to the opposite one then allowed me to open it up and use it...  

    None of the PC1600 patches on my site should be .exe files?
  • HI There,
    So, I've been trying to get my PC1600 is work with my Microwave 1. 
    I'll just jump right in:

    First, I tried the easy route and downloaded the MW1 Template from this site. But to no avail. I'm not sure if I did something wrong while sending the .mid file. Or perhaps, and this is what I was thinking, the PC1600 needs an update of some kind..

    So:
    Things that happened when I downloaded the .mid file.
    At first I saw an error message for a second, I walked away from it, came back and saw it said "microwave" etc.. in the display.
    I then tried to control some parameters, but nothing..
    So, I erased the patch, and sent another(from my mac, w/ sysex librarian software, and midisport 2x2) to the PC1600.
    And all I saw the next time around were the error message(s).

    Any help would be great!

    Thanks everyone,

    Finetime.


  • First, you have to be sure that you are using the appropriate patch - if you have a PC-1600 vs. PC-1600X.  There's microwave patches for both on the site...

    Next - as you can see in the thread above, sometimes the patch dumping can be finicky, and also the files that are on my site have been sent by different people, so sometimes you have to mess with them a little bit.  First thing I would try is to use a different app to send the file - you can open the file up in any DAW, and then just "play" the file to your Microwave.  You can also try changing the suffix of the file from .mid to .syx - sometimes that helps...  

    The other thing to try is to try to send other patches to the PC-1600 -- just to be sure that you have the process down, and that the problem is not with particulars of that one file... Hope that helps!
  • HI Dan,

    Going to give these a shot today. I do have the older PC 1600, so I downloaded the patch for that one.
    After trying it the first time, I actually tried to download the the patch for the 1600x to see if that worked. But it looks as if that file is missing from the site. 

    finetime
  • Hmm... I do see that that file is corrupted for some reason (you can download using Save File As... but it still won't work...

    Even if your PC1600 doesn't have the "X" on the outside, it might be one - look at the screen when you power it on, and it will tell you what it is, including what version of the OS...
  • Hey Dan,

    Thx for the support! So I got the PC1600 working with the MW1, sounds great and thank you. It was being a little finicky, and showed an error in the edit buffer when I dumped the midi map, anyhow.. Everything seems to be working fine w/ all the fader assignments. Thank you so much.
    I had another question, not sure if you'll be able to help on this one.
    I'm having a terribly difficult time trying to get the pc1600 midi info recorded onto my MMT8.

    I've been using a korg K49 with it's midi Out, sent to the midi In of the PC1600. and then the midi out of the PC1600 plugged into the MMT8's midi In.

    Nothing seems to come out of the mmt8 when I do this, but the memory looks like its being used.
    Anyhow, any thoughts. Please let me know!
    & thanks again.

    All the best,

    Finetime
  • Only thing I can think of with the MMT8 is whether or not it has some kind of MIDI filter invoked, so that it is ignoring certain messages (e.g. Sysex)?
  • edited July 2011
    Hello

    Version 2.30 ???

    Thanks, gwblaine [at] gmail [.] com
  • Large Picture of my PC1600X: http://gwblaine.blogspot.com/
    Need to click on the Picture.
    image
  • edited July 2011
    Peavey, PC1600X, PC-1600X, PC 1600X, MIDI Command Station, v2.30 ???
  • Look in PC1600x Forum here for an Awesome PC Editor, a full PDF Manual and username and Reg. code.

    I have had these for years and it is time to share them, yeah the name is mine so please

    keep it around with the hyphens in it so people don't google my name to it.

    thanks, all i ask

  • Ok I must be missing something basic- how do you send a sysex to the PC1600x?
    I have tried both syslibrarian on a mac- jsynthlib on a PC and can not get it to do anything.
    the OS is at 2.2 and the unit seems to work fine. I have used it with Reason and a little with the built in JX1080 preset but can not get it to accept a new preset.

    Please clue me in. . . .

    M
  • Most likely the preset you downloaded got converted to text or something. Try right clicking the link and do "save as" or similar.

    Also sometime you can try alternate suffixes for the file; if it's .mid try changing it to .syx, or vice versa.
  • edited March 2013
    Thanks Dan,
    I tried your suggestions.
    I am trying to use the pc1600x files for the jx-10se mod by

    Colin Fraser.
    http://colinfraser.com/jx10/JX10se-PC1600.zip
    I have been unable to get them to load on the 1600x.
    I am guessing I am missing something basic.
    When I try to upload using PVC or Jsynthlib I have the midi in channels matching in both the software and on the 1600x.
    I know the PC is sending midi at least as it will drive synths.
    I see that using a preset on the 1600x will cause midi monitor to register

    data.
    I tried downloading some presets from Peavey to see if I could get them to load but that also did not work.
    Is there something special I need to do to get the 1600x in the right mood?
  • The only thing I can think of is that maybe the "Device Number" (see the PC1600 manual) is set to something that's preventing your computer's Sysex data stream from reaching it?   Just a wild guess...
Sign In or Register to comment.