APP & IK Multimedia Plugs

edited July 2013 in Audio Plugin Player
Hello developer & forum,
I'm using APP 1.3 to load SampleTank, Miroslav, Sampletron... from the Total Workastastion bundle from IKM.
After loading the AU, when I click to view the plugin, I get a blank window (white), but after I click in the window, it draws the interface and it shows up fine.
As soon as I click on the plugin interface to select the path folder to where the instruments are located, APP crashes.

I'm not able to use these plugins within Digital Performer 8.04 because they're still 32 bit and was hoping APP would take care of that. 
IKM needs to get with the program.
I'm also attaching the crash report. Ok! Not able to attach the file... I'll paste it below

My os specs:
iMac 3.06 GhZ, 8 GB RAM, OS 10.8.4


Process:         Audio Plugin Player [500]
Path:            /Applications/Audio Plugin Player.app/Contents/MacOS/Audio Plugin Player
Identifier:      com.defectiverecordssoftware.AudioPluginPlayer
Version:         1.3 (1.3)
App Item ID:     489844081
App External ID: 14582432
Code Type:       X86 (Native)
Parent Process:  launchd [152]
User ID:         501

Date/Time:       2013-07-31 12:54:14.795 -0400
OS Version:      Mac OS X 10.8.4 (12E55)
Report Version:  10
Sleep/Wake UUID: 47AC6F6E-D621-455A-B9D5-50E5B8E71182

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000004e59ffbc

VM Regions Near 0x4e59ffbc:
    MALLOC_LARGE           000000000f700000-000000000fa7c000 [ 3568K] rw-/rwx SM=PRV  
--> 
    __TEXT                 000000008fe83000-000000008feb6000 [  204K] r-x/rwx SM=COW  /usr/lib/dyld

Application Specific Information:
objc_msgSend() selector name: setCanCreateDirectories:


Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               0x9099ca87 objc_msgSend + 23
1   com.apple.AppKit               0x9a18b022 _NSNavCreateChooseFolderDialog + 445
2   com.apple.NavigationServices   0x93b4e951 NavCreateChooseFolderDialog + 67
3   com.apple.NavigationServices   0x93b4e728 NavChooseFolder + 98
4   com.ikmultimedia.vpa.Philharmonik 0x0a2cfa10 epiPath::userDialogGetFolder(char const*) + 260
5   com.ikmultimedia.vpa.Philharmonik 0x0a24e940 0xa211000 + 252224
6   com.ikmultimedia.vpa.Philharmonik 0x0a2ae467 epiAlphaPanel::clickRelease() + 159
7   com.ikmultimedia.vpa.Philharmonik 0x0a2d46a6 epiWindowsCar_mouseEvent(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 260
8   com.apple.HIToolbox           0x92ce99bb _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long (*)(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*)) + 36
9   com.apple.HIToolbox           0x92b71394 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1343
10  com.apple.HIToolbox           0x92b70780 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 430
11  com.apple.HIToolbox           0x92b84655 SendEventToEventTarget + 88
12  com.apple.HIToolbox           0x92ba45c7 ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 2141
13  com.apple.HIToolbox           0x92b7183f DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2538
14  com.apple.HIToolbox           0x92b70780 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 430
15  com.apple.HIToolbox           0x92b84655 SendEventToEventTarget + 88
16  com.ikmultimedia.vpa.Philharmonik 0x0a2d60dc epiWindowClass::enterModalLoop() + 148

Comments

  • Sorry APP is not working for you with these plugs...  From the crash log, it seems that it is crashing within Apple code, which was called immediately after a call from the IK plugin...

    I don't have any of these plugins myself to test with, so I'm afraid there's not more that I can do at this point, as it does seem to be a problem between IK and Apple somewhere...
  • Hello Dan,
    This is not your fault. These plugins, received their last update in 2009 and up until Snow Leopard (10.6.8), they ran fine. 
    Now in mountain Lion,, I have the drag the actual sound library into place because the installers don't even work with the new OS - something that IK refuses to fix too and thats an easy fix.

    Anyway, thank you for your response. Much appreciated,

    GSPro
  • Thanks for the info and background!
  • Hello

    I bought APP, just for using it to monitor all music thru IK:s ARC2 plugin, but it seems to be
    only plugin that does not work with it.
    It only shows message:

    Registry error
    Please ensure this product has been installed properly

    In logic etc. it works pefectly.
    Im running on osx 10,8,5

    So what to do?


  • I apologize for the problem.  Although I can't tell for sure as I don't have ARC2, it is likely that this is a problem related to the copy protection used by the plugin, and the constraints that Apple puts on applications sold in the App Store (apps have to exist in a "sandbox").  I'm still trying to figure out a way to get around these restrictions - I hope to have an update for the application soon.
Sign In or Register to comment.