Cyclic v1.5 now available

edited November 2013 in Cyclic
There are many new features, as well as several bug fixes and a major effeciency improvement:

New Features
  • VST plugin instrument hosting for up to 3 plugins
  • Send two separate continuous controller MIDI streams (CC1 and CC2)
  • Per step Velocity, Gate, CC1 and CC2 control
  • Override Note, Velocity and/or Gate options per subsequence
  • Override Velocity to zero, allows for “CC-only” subsequence
  • MIDI CC control of almost all parameters, with easy to use MIDI learn feature
  • Constrain random value ranges
  • Added . key to toggle between Main and Setup
  • Added P key for Panic
  • Added LED for MIDI clock

Improvements/Bug Fixes
  • Significantly reduced CPU use, especially on graphics-challenged systems
  • Active step now highlighted in white, easier to see
  • Updated Mutable Instruments logo
  • Added tool tip for presets to remind how to store/recall presets
  • Fixed Preferences name

It’s a free update for existing users. Price remains the same for others.

Comments

  • This update is fantastic! So far I've tried the new MIDI CC, gate per step, and random value constraint features and they're great. I'm blown away by how much is MIDI-controllable! This is an absolute dream sequencer now.
  • Thanks for the very nice comments!!
  • WOW, Great Upgrade, truly amazing,....low CPU, added features, MIDI, fine tuned random and upper lower limits, and up to 3 VSTs, just fantastic.:-)...

    On W-7 I found that none of the resets want to midi learn? I will try other functions.

    I like the toggle for main/setup (>.) on PC...nice thing would be to assign "note/velocity/gate/cc1/cc2 to a keyboard, (not a request, just an extra icing on the cake).

    Many thanks for this "FREE upgrade", really excellent.

    PS i can't figure out the CC1,2 function..lol... I know what they are, just don't know how (and to "what") to send it to...hardware, standalone VST?


  • Thanks for the nice words Karel - and apologies that it took so long!  :-)
    On W-7 I found that none of the resets want to midi learn? I will try other functions.
    Make sure that the subsequence is active (not muted) when trying to MIDI learn its reset.  Let me know if that fixes it for you.  I just re-tested it on a Mac (not at a PC at the moment), but I would expect to behave the same on Windows.
    I like the toggle for main/setup (>.) on PC...nice thing would be to assign "note/velocity/gate/cc1/cc2 to a keyboard, (not a request, just an extra icing on the cake).
    Good idea, will keep it in mind in the next update.  Maybe the [tab] key?
    PS i can't figure out the CC1,2 function..lol... I know what they are, just don't know how (and to "what") to send it to...hardware, standalone VST?
    The CC1 and CC2 info is sent to the same device/MIDI channel that the subsequence is set to - either hardware or software.  In the subsequence section, you configure them to specify what CC number you want them to transmit to - this will depend on your hardware/software, and what parameter you want to control there. In the circle, you specify what the value should be for each step that it will transmit.
  • Better later than never;-) it's great, worth the wait, besides I have other "toys" to play with....

    Actually none of the resets work as midi assignment, they are recorded in the setup midi control page, but are inactive. (they learn, but not respond, if that makes any difference)
    Not muted, etc, made sure of that...

    Scroll through Tab key sounds great:-)

    I have to play more with CC1,2...thanx for explanation.
    cheers and thanks:-)

  • Re: resets not responding to MIDI control - ugh, you're absolutely right.  They "learn" OK, but do not respond correctly.  Will investigate, thanks for the report.
  • Yes, remote control of the resets is very broken, sorry.  Will work on a fix...
  • Dan, I'd be happy if only the reset All worked, why the others? It's nice that they "blink" once they hit 1st step, but the master one is the only one necessary....
  • Some people may want to manually retrigger the individual sequences, rather than all of them...

    BTW, I've identified the problem in my code, now just have to come up with a fix.  It's unfortunately not straightforward, but hopefully solvable once I get some time....
  • Quick note to say that version 1.5.1 is now available.  It fixes the remote MIDI control of Reset All and Resets.  Karel, note that sometimes it's a bit finicky when mousing over the Reset and Reset All controls when doing MIDI learn - you have to mouse over the very edge of them for them to turn blue.  Will continue to work on that.

    Also, the Tab key to cycle through the event array tabs has been implemented.
  • Thank you for the quick fix and the scroll improvement...very nice
    Like you say, it is a bit tricky to get the master reset turn blue, but once done, it's stored.
    Truly a new sequencer...love the new features, low cpu, vsts etc...
    Thanx a lot...and Happy Thanksgiving:-)
  • edited December 2013
    One thing I found is, that if I change notes in note "Values"  (under on/off status) TAB no longer works...

    And in "Velocity" mode, both values seem to reset to the value on left- (lower one) and soon all to 0=no sound, (if I make midi learn to a button for randomizing min/max)
  • One thing I found is, that if I change notes in note "Values"  (under on/off status) TAB no longer works...
    Yeah, I've noticed something weird with the Tab key functionality as well, sometimes it works, sometimes it doesn't.  I will try to figure it out.
    And in "Velocity" mode, both values seem to reset to the value on left- (lower one) and soon all to 0=no sound, (if I make midi learn to a button for randomizing min/max)
    I can't reproduce this - can you be more specific about the exact steps you are doing and what you're seeing happen?
  • ....sorry false alarm....I tried to reproduce it as well, and I can't.
    This is how I did it:
     I assigned MIDI to "Values" in Velocity mode to a momentary button . If I pushed it, (via midi) it would reset to left value. like if left is 90 and right is 127, both will reset  90...and after few times, L=R reset to 0 and if I push, it flashed 127 (min/max).

    But now it works correctly.
    Sorry, must have been a small midi glitch...
  • OK, let me know if it occurs again.
Sign In or Register to comment.