The volume is too low

edited February 2012 in General MIDI Player
I have to turn the speakers all the way up, and it is still too quiet. What am I doing wrong?

Computer volume is all the way up. I can hear other programs just fine.

Comments

  • Hmm.... not sure about that one.  

    Can you check to see within your Sound control panel if the volume is all the way up as shown there?  Are you using the Built In audio on your Mac, or using another audio interface?
  • I've just upgraded to version 1.1 and the volume is still to low - even with the Sound output in the control panel turned up full. Any chance of adding a volume control to the application?
  • I have no control over the General MIDI volume - it's a built in Mac function.  I'm telling the General MIDI device to play the notes at the maximum volume already....

    In the Sound Control panel - can you check to see if the volume on the Sound Effects tab is all the way up?  I'm not sure if that will have any effect, but it's worth a try.   Also, can you confirm that you're using the Built In Mac audio device, or a 3rd party audio device?

    Also, any difference between notes played by mouse, QWERTY, or MIDI?
  • I dug into this a bit more, and I'm happy to report that I think I have found a solution for the low volume problem.  Will try to get it into the next update!
  • The new 1.2 version of General MIDI Player was just approved by Apple, and it should be in the App Store soon so you can update - it includes a Volume setting, that will allow you to boost the volume up louder than it was in previous versions!

    Thanks for the feedback...
  • I have version 1.2 and I still seem to be suffering from the same problem...other apps have "normal" volume, but General MIDI Player is super quiet.  Mouse, MIDI, or QWERTY mode makes no difference.  Using built-in Mac audio, and the volume in the Sound Effects tab is maxed.
  • The volume in the Sound Effects section should not matter, the only thing that should make a difference is the main Output Volume, and the Volume within General MIDI player.  At this point, I've maxed all possible volumes within the application that I can think of... so I'm afraid I'm out of ideas, sorry!!  

    If I think of anything else I will post back here....
  • I just downloaded General Midi and I too am having volume problems.  All of my output volume is at max and is max on the Midi and volume is still low.
  • For those with this volume problem - have you tried with different General MIDI instruments?  Some are quieter than others.  Also - if you have another application that can play GM instruments, are they any louder?  

    Still trying to understand if this is a problem with my code, or just an inherent problem of the Mac's GM instruments...
  • I was looking into purchasing this app because the volume problem makes the Synfire tutorials useless. It's not just your application. They seem to know what the problem is if you want to look into it: http://www.synfire.com/content/midi-playback-very-quiet-mac-os-x-107-lion.

    I guess I need to look into a full blown GM MIDI Module in software. Any ideas?
  • Thanks for that - I'll see if I can use that info to improve things on my end too...   Here's an example of one of the Apple threads on the issue... 
  • Happy to report that the volume issue is much improved in new version 1.3, now available on the App Store.  Also added a new Reverb control.
Sign In or Register to comment.