M-185 v2.1 now available

Happy to report that a long overdue update to M-185 is now available, v2.1.

New Features
• Now runs only as 64-bit application, and only allows for hosting of 64-bit plugins
• Now supports hosting of VST, VST3 and AU plugins (AU Mac-only)
• Plugin blacklisting, for plugins found to be problematic on app startup
• Basic support for Dark Mode (menus and title bar only, Mac 10.14.x or greater)

Improvements / Bug Fixes
• Entirely new plugin scanning process, should be more reliable and thorough, and avoids crashes.
• Fixes major bug on newer Mac OSs, which occasionally resulted on blank white screen on startup or app refusing to launch
• Fixed bug with ReWire not working on Windows 64-bit systems
• Fixed bug where duplicate audio plugin entries seen if only one plugin present
• Removed option to choose whether to operate with or without plugins
• Minor user interface improvements

As always, this is a free update for existing users, and the price remains the same for new users.

Please note that for Windows users, the installer will NOT remove any previous, 32-bit installs of M-185. So to avoid confusion between versions, you may want to manually uninstall older versions before installing this new one.


  • HI Dan, best wishes in 2019.

    Very nice that you updated this one and Cyclic. (None actually worked since I upgraded to W-10)

    I followed instructions on uninstalling first and installing new version.
    One problem I have is that nowhere in the installation process I could choose my VST folder.

    Both sequencers scanned wrong VST folder (I have 2) and blacklisted one VST but I can’t load anything, because it is not connected to any folder?
    All I get is the Windows default synth.
    I am on Windows 10 64bit.

    Thanks, kind regards Karel

  • Hi Karel, and Happy New Year!

    Yes, there is no ability in the new versions to specify a custom plugin folder path. I definitely debated whether or not to do this; I’m now using default plugin scanning behavior that Max offers me (M-185 and all of my apps are built using Max, as a reminder), which is MUCH more robust and complete than my previous custom built one. But the downside is that it (currently) doesn’t offer the ability to use a custom path for the plugin location. All things considered, I thought the approach I took was the best one for now.

    On Windows, it uses whatever path is in your registry for plugins; it’s the VSTPluginsPath string value under the registry key HKLM\Software\VST. So currently, with the new version of Cyclic, that’s what you’ll be limited to using. I’ve already made the request to Cycling 74 to add the ability to Max to allow for a custom path, so we’ll see if they deliver. If so then I’ll add back the functionality to M-185, Cyclic (and Klee, whose update I'm working on now).

  • edited January 2
    Thanks for replying, what’s strange is that I can’t even open the folder that it scanned? I have some Arturia plugins that flashed scanning but clicking on the folder button doesn’t open the folder. Why not, if it scanned and blacklisted one VST?
    If it opened the folder I could find path and copy/paste my VSTs there but it’s not working. Maybe it works on Apple OS, but all my Windows software asks for a folder and you can change folder. (Actually if I didn’t specify a folder, it will create a Steinberg VST folder)

    I’ll fiddle with it tomorrow to seee if I can get it working.

    Best Karel
  • I'm not sure exactly where in the OS you are when you say that "clicking on the folder button doesn't open the folder"? I've never experienced that - perhaps some weird permissions thing?

    Anyway, yes, the problem is that on Windows, there has never been a well-adhered to default location to place VST2 plugins, despite Steinberg having attempted to address partly through its VST evolution. In theory, with VST3, there's now supposed to be a standard, so we'll see if the vendors adhere to it. See https://helpcenter.steinberg.de/hc/en-us/articles/115000177084-VST-plug-in-locations-on-Windows

    As I said, I've made an appeal to Cycling for them to add the ability to provide a custom path for the VST plugin location. Until then, the easiest short term solution for you would be to change your Registry setting to path of your desired plugin folder. It's easy to do, just open Regedit, navigate to HK Local Machine\Software\VST, and change the String entry to your desired path.
  • dnigrin said:

    I'm not sure exactly where in the OS you are when you say that "clicking on the folder button doesn't open the folder"? I've never experienced that - perhaps some weird permissions thing?.

    ^^^ I meant the button on the sequencer itself to open and load a VST....are we talking about the same thing?

    I will follow your tip on location of the folder and simply copy the VSTs in there...I was/am on iPad so I didn’t try and was busy...

    Thanks a lot for your help and clarification... I thought originally that the setup didn’t go as planned...
    (I have Reaktor and Ableton that use the same folder path)

    Regards Karel

  • Do you mean the button in M185 that has the three little dots on it in the Output section, that appears when you have selected a plugin from the dropdown menu?

    If so - that's not a button that allows you to select a plugin, it's simply the button that opens up the already selected plugin's editor window. Maybe that's what's causing the confusion?

    Anyway, let me know how you make out!

  • Yes, that’s the button...
    I thought that’s the way to open the folder. So now I’m completely confused
  • PS, something happened to my post, got eaten half way...
  • Hi Karel - please let me know what part is still confusing, and I will try to clear things up!
  • Ok, the thing is I don’t know how to load a VST in. At least one of those that got scanned and passed.
    They are not showing anywhere. The area where VST 2 and 3 are is empty.

    How do I load a VST?

    Thanks, sorry for being a nuisance
  • edited January 6
    Not a nuisance at all, I hope everything is working right!!

    So in M185, the plugins are listed at the bottom of the dropdown in the Output section, the lower right of the Main window. On top will be your MIDI devices, then you should see your plugins showing at the bottom. Like in this picture. Do you not see any plugins there?
  • And again to be sure - the plugins MUST be the 64 bit versions.
  • Hi Dan,
    Thanks,....well I don’t have a folder VST in "HK Local Machine\Software\VST"
    Strange, isn't it? I didn't delete it and I think my Windows are not corrupted, being fairly new...
    Is there some other way? I'm going to create a shortcut and put it into the VST3 folder and see what happens...
    Am I the only one having this problem???
    registry.gif 11.3K
  • OK, just tried shortcuts, copying folders etc, nothing...still scans the same VST3 folder and that's it...
    don't know...
  • You can certainly just make a registry entry there yourself. The string entry should be named VSTPluginsPath, and then just enter the path to your desired plugin folder. See the first image below. Also know that there might be another VST entry in the WOW6432NODE; this is for 32-bit applications running on a 64-bit system. See second image.

    You can read some of the background to this general problem on the Steinberg site, where they go into how there never was really a great folder location for VST(2) plugins. With the VST3 definition, there's now a mandatory location, which should address the problem moving forward. https://helpcenter.steinberg.de/hc/en-us/articles/115000177084-VST-plug-in-locations-on-Windows

    Let me know if things work after you make that registry entry.
  • Thank you very much Dan, will give it a try...seems simple enough.

    I did read the Steinberg link.

    Best, Karel
Sign In or Register to comment.